Terug naar overzicht
Opgelost

ZenchefOS is offline

Apr 29, 2026 at 1:53pm UTC
Getroffen services
ZenchefOS

Opgelost
Apr 29, 2026 at 2:05pm UTC

ZenchefOS is hersteld.

Aangemaakt
Apr 29, 2026 at 1:53pm UTC

ZenchefOS is offline gegaan.