Terug naar overzicht
Opgelost

ZenchefOS is offline

Sep 28, 2025 at 4:50pm UTC
Getroffen services
ZenchefOS

Opgelost
Sep 28, 2025 at 4:53pm UTC

ZenchefOS is hersteld.

Aangemaakt
Sep 28, 2025 at 4:50pm UTC

ZenchefOS is offline gegaan.