Terug naar overzicht
Opgelost

ZenchefOS is offline

Aug 26, 2025 at 10:40am UTC
Getroffen services
ZenchefOS

Opgelost
Aug 26, 2025 at 10:43am UTC

ZenchefOS is hersteld.

Aangemaakt
Aug 26, 2025 at 10:40am UTC

ZenchefOS is offline gegaan.