Terug naar overzicht
Opgelost

ZenchefOS is offline

Feb 14, 2025 at 5:05pm UTC
Getroffen services
ZenchefOS

Opgelost
Feb 14, 2025 at 6:11pm UTC

ZenchefOS is hersteld.

Bijgewerkt
Feb 14, 2025 at 6:02pm UTC

ZenchefOS is offline gegaan.

Bijgewerkt
Feb 14, 2025 at 5:18pm UTC

ZenchefOS is hersteld.

Aangemaakt
Feb 14, 2025 at 5:05pm UTC

ZenchefOS is offline gegaan.